Jump to content
Ketarin forum

Any idea why I get this error?


Recommended Posts

I am having trouble with my downloads and wondered if anyone had any advice of what the problem is or how to fix them.  Here is the error that I get:

45 Grand 47's Challenge    The downloaded file is not a binary file type (text/html; charset=utf-8). Possibly there is an error page. Status code: 200 (OK) (https://1drv.ws/u/s!AjyAcx9AtLxQjWG_Vse4ChqmMA2a)

Funny thing is the links work if entered into a browser, the links will also start working after a while in Ketarin.  While writing this about 30 minutes into testing and getting the error, I restarted Ketarin, running as Administrator and my downloads now work.  Not sure if Run as Administrator helped, but any help would be greatly appreciated.

Link to comment
Share on other sites

They're probably performing user-agent validation. I just tried the link with a browser, curl, wget, and with curl using a Chrome user-agent. None failed. I even tried using curl with the default Ketarin user-agent ("Mozilla/4.0+(compatible;+Ketarin;++https://ketarin.org/)") and that worked too. You have probably replaced the default user-agent on the Advanced Settings tab with one OneDrive doesn't like. Remove your custom UA or replace it with a standard generic UA and you'll probably be okay.

Running as administrator should almost never be necessary. If you're not downloading to a protected directory (ProgramFiles, Windows, certain subfolders under ProgramData), a drive or folder without your user being granted NTFS write permissions, or a network share that has limited availability, then you should not have any need to run elevated.

Also, running elevated would make no difference in the OneDrive server response.

It is entirely possible that OneDrive was just having problems and the cached redirect worked fine in your browser but did not work in Ketarin since Ketarin re-parses it each time. MS has had several network issues over the last couple months that would account for this problem, though none reported in the last week. It could also be a network issue with your own ISP that would result in the same problem. I have several local clients that can't visit some websites because a local ISP has had backbone connectivity problems for over 2 months now. Repeatedly reporting the problem to them has gone unacknowledged. Using a VPN, these clients have been able to work around their backbone connectivity issues. This might be a solution for you assuming that it's a similar problem.

Seeing the actual server response would be a good place to start troubleshooting if changing the UA doesn't help. You can use the "when an application update fails" script to pipe the values to a text file.

Link to comment
Share on other sites

  • 1 month later...

It simply means that when git inspects the actual content of the file (it doesn't know that any given extension is not a binary file - you can use the attributes file if you want to tell it explicitly - see the man pages).

Having inspected the file's contents it has seen stuff that isn't in basic ascii characters. Being UTF16 I expect that it will have 'funny' characters so it thinks it's binary.

There are ways of telling git if you have internationalisation (i18n) or extended character formats for the file. I'm not sufficiently up on the exact method for setting that - you may need to RT[Full]M

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.