Jump to content
Ketarin forum

Strange FTP issue


Recommended Posts

I don't often use FTP URLs, but as far as I can recall, they've always worked for me since 1.8.6.

I switched all the ones I had that used FTP to an HTTPS URL though, so don't have a working one to compare with right now.

Anyway, I'm adding NcFTP. It uses an FTP URL (surprised?). The download URL includes spaces:

ftp://ftp.ncftp.com/ncftp/binaries/Setup NcFTP 3.2.6.msi

ftp://ftp.ncftp.com/ncftp/binaries/Setup NcFTP 3.2.6.msi

Unfortunately, I get the following error every time:

NcFTP	The format of the URI "" cannot be determined. (ftp://ftp.ncftp.com/ncftp/binaries/Setup NcFTP 3.2.6.msi)

I've tried replacing the spaces with "%20" and "+". Both return a different error (550). 

I've tried using a different FTP download from the server:

NcFTP	The format of the URI "" cannot be determined. (ftp://ftp.ncftp.com/ncftpd/2.8.7/ncftpd-2.8.7-aix5.3.0-export.tar.gz)

Is it the FTP server that's causing the problem or am I missing something else that's going to be obvious once I investigate?


Link to comment
Share on other sites

  • 4 weeks later...

Thank you, @floele

You inspired me to dig through the app again and I discovered there was an unused variable that was opening a defective URL and *that* is what was triggering the error. Once I removed that variable it's working fine.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.