Jump to content
Ketarin forum
jokerfool

Could not create SSL/TLS

Recommended Posts

 The request was aborted: Could not create SSL/TLS secure channel.

 

Getting this alot, whats happening or whats causing it. Changing through beta to download doesn't make a difference.

 

Share this post


Link to post
Share on other sites

Hello,

I get the exact same problem with the latest 1.8.8 b4. It just started happening recently (within the past month) and it seems to only happen with FileHippo. All my other apps update fine.

If there's any way I can help, please let me know.

Thanks!

Share this post


Link to post
Share on other sites

Hello, I had the same issue, and tested out 1.8.8 b4 to see if it worked any better.

Strangely enough, it seems like in the beta version, it gives me that "SSL" error the first time I click on Update, but if I try again, it'll work.

Tried 1.8.7 again to see if it was the same there, but in that version it'll just fail with that "SSL" error message every time.

Share this post


Link to post
Share on other sites

Happy New Year everybody :)

I also have this problem (only Filehippo) and after a few weeks of searching I finally found a reason for this error and a solution.

It seems Filehippo changed their SSL certificate to only allow TLS 1.2 which got me thinking: why does the download work in e.g. Firefox but not in Ketarin? I then narrowed it down to Windows/.NET and found registry setting "SchUseStrongCrypto" which forces .NET to use newer settings for connections. You need to create the following keys in your registry

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319
"SchUseStrongCrypto"=dword:00000001

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319
"SchUseStrongCrypto"=dword:00000001

After that a reboot may be necessary. If you don't know what the registry is let a professional do that for you.

I'm sure there is a Windows 7 update somewhere that (should) fix that but I could not find it.
Also after the recent catastrophic Microsoft updates and the ... Windows 10 forced updates it is not in my interest to mess up a fine running Windows 7.

Hope this solution works for you too!

 

Share this post


Link to post
Share on other sites

thank you for sharing, @herbert2 !

be aware that this change affects every .net application on your system, including Office 365, some application updaters and more. while it's a good security fix to employ in a general sense, some third-party stuff doesn't behave with strong security, so this change can break certain apps that communicate with sites that don't support TLS 1.2

Share this post


Link to post
Share on other sites
On 1/11/2018 at 4:26 AM, herbert2 said:

Happy New Year everybody :)

I also have this problem (only Filehippo) and after a few weeks of searching I finally found a reason for this error and a solution.

It seems Filehippo changed their SSL certificate to only allow TLS 1.2 which got me thinking: why does the download work in e.g. Firefox but not in Ketarin? I then narrowed it down to Windows/.NET and found registry setting "SchUseStrongCrypto" which forces .NET to use newer settings for connections. You need to create the following keys in your registry


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319
"SchUseStrongCrypto"=dword:00000001

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319
"SchUseStrongCrypto"=dword:00000001

After that a reboot may be necessary. If you don't know what the registry is let a professional do that for you.

I'm sure there is a Windows 7 update somewhere that (should) fix that but I could not find it.
Also after the recent catastrophic Microsoft updates and the ... Windows 10 forced updates it is not in my interest to mess up a fine running Windows 7.

Hope this solution works for you too!

 

Thank you for posting this. I had the same problem on my Win 10 Home version 1709 system. Added the registry keys you noted and now Ketarin works with FileHippo again. 

Hopefully I won't have problems with other applications, will report back here if I do...

Mahalo,

Harry Z

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.