Jump to content
Ketarin forum
  • Announcements

papo

Textual variable is not showing under Column

Recommended Posts

How the Custom column should work with Textual variable?

I used to be able to see value of a Textual variable under Custom Column added by a script,
but only when I added the value also to CachedContent property.
I was using sqlite for this. The value updated only after re-start, but it was working ok otherwise.

Recently the whole Column showing my custom variable: "Current Version" remained blank and I thought this was broken by an update,
but now I tried various old versions and the value is still not shown.

I found an old jobs.db and the previous functionality returned,
but the curious thing is, with the recent jobs.db, which wasn't showing my "Current Version", if I blank the TextualContent
and keep only CachedContent, it will show it under the Column. I am doing this using PS:

$app.variables.$Name.TextualContent = $null # "" works too

I become quite certain that either I am doing something wrong, or this feature doesn't work for Textual variables.

CachedContent is shown in Column, but TextualContent in UI > App > Edit > Variables > Textual content

Shouldn't TextualContent be shown under Column for Textual variable?
Could they maybe be interlocked for Textual variable type, to keep existing scripts functional?

 

Share this post


Link to post
Share on other sites

thanks, I was converting some batch/sqlite scripts to PowerShell.
one problem I hit was, that I couldn't create new variable.
That thread you pointed out is describing newly added constructor and how to use it.
It's working fine, I don't have problem there.

This is another issue, which I already had while using batch/sqlite.
It seems like that when you add a Custom Column with Textual variable,
lines under the Custom Column are showing CachedContent,
regardless of type of variable used being Textual (StartEnd / Textual / RegularExpression)

When you set Textual variable in Ketarin, only TextualContent is updated and
without a workaround, where I am copying values from TextualContent to CachedContent,
the Custom Column shows nothing.

Of course the workaround is not perfect, but satisfactory for my case.
My question being, is this happening only to me? Or is this a bug/program limitation.
I think this problem is related.

Thirdly, I don't see a way to update the view. When I change the variable,
old value is still showing under Custom Column. I can open/close Settings and it will update,
but I would expect there should be PS way to refresh the view.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×