Jump to content
Ketarin forum
  • Announcements

jokerfool

Members
  • Content count

    35
  • Joined

  • Last visited

Everything posted by jokerfool

  1. Create Log

    How do I create that log? Is this wrong? START Ketarin.exe /database=home_apps /log=FILENAME Because it comes back empty.
  2. Create Log

    I double click the batch file Contains: @ECHO OFF start "" /wait G:\Home\Ketarin.exe /database=G:\Home\ home_apps /log=G:\Home\filename.log EXIT It loads the file, Ketarin opens, it creates a log file but the log file is empty. I leave Ketarin open for awhile in case too many apps, but it seems if I have 500 or 5 the log file is still empty. What am I missing here, can't be this hard. I also checked the log permissions and changed the permissions so its full control and not read only. It doesn't seem to make a difference if the file is home_apps or home_apps.db It creates the log file just nothing is written to it. I've also tested from a command prompt and elevated and same thing. Thanks for trying to help me.
  3. Create Log

    I am running the command from a batch file Yes running the batch file from where Ketarin is located Database is in the same directory next to batch and ketarin Windows 10 Home No networks Standard process
  4. Create Log

    So when I run that command this is what happens and yes the database is in the same directory as the exe I run the batch file, Ketarin opens, the cmd window closes, this file is created home_apps.db_2017-08-19.bak I close Ketarin and that's it. So nothing is exported to XML Nothing in the AppData folder I also don't get any file created ending in .log.
  5. Create Log

    Doesnt do anything, Ketarin opens then you close it and nothing, no log files appear.
  6. Create Log

    Any help please?
  7. Create Log

    This command wont work because it doesn't have a trailing .db start "" /wait Ketarin.exe /database=home_apps.db /log=FILENAME.log Its just home_apps It also produces an empty result if I try and add the .db onto the end of it. Also the backup file thats created its usually 1.4MB and now its only 21k
  8. Updating Bug

    When I add a new application for example Blah.zip and rename the AllApps to Blah and head on over too Commands and see this: 7z x "{file}" -o"{root}GEGeek_Toolkit\ProgramFiles\{category}\Blah\" -y del /q "{root}GEGeek_Toolkit\ProgramFiles\{category}\Blah\*.zip" When the file is first update, Blah.zip is downloaded, extracted, then deleted. But when running Check For Update and we come across this folder, the update will always tell the user the Blah folder an update is required because Blah.zip can't be located so we can't run a check to see if there is an update, so we must now instruct you to download the new update and repeat the process above. So lets remove this line: del /q "{root}GEGeek_Toolkit\ProgramFiles\{category}\Blah\*.zip" We try again and now we've all green ticks, but now we've a bigger problem. If Company Blah releases an update and inside the original Blah.zip it sais Blah but the new update they release is called Blah 2.0 then we've a problem because the original folder called Blah will still be there and a disaster in the making. Lets go ahead 1 year and now the Blah folder has 50 updated folders all different versions. Is there only way to solve this to use that Variable option? Because I can't see any other way to check for an update without the file zip physically being located in the folder. Thank you.
  9. Updating Bug

    So how can I rectify the issue I have and set it back to the beginning? Because when I select all and run a check for update 90% come back green ticked even though the files haven't been downloaded. Any help please. Thanks Jason
  10. Ketarin 1.8.8 (beta)

    So I put your latest beta to the toolkit and found that if I have the "Ignore File Information" unticked and I check for an update it needs updating, once updated I check again and it still says it needs an update. Removing the entry and re-adding doesn't seem to make any difference. Closing Ketarin and re-opening doesn't seem to make any difference This is the file I tested on: Portable Update <?xml version='1.0' encoding='utf-8'?> <Jobs> <ApplicationJob xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" Guid="e4a8d52f-0a6c-4cc2-bcdf-d1fa75d7c1be"> <WebsiteUrl>http://download.wsusoffline.net</WebsiteUrl> <UserAgent /> <UserNotes /> <LastFileSize>214469</LastFileSize> <LastFileDate>2016-07-13T01:27:34+10:00</LastFileDate> <IgnoreFileInformation>false</IgnoreFileInformation> <DownloadBeta>Default</DownloadBeta> <DownloadDate>2013-02-25T10:28:28</DownloadDate> <CheckForUpdatesOnly>false</CheckForUpdatesOnly> <VariableChangeIndicator /> <HashVariable /> <HashType>None</HashType> <CanBeShared>true</CanBeShared> <ShareApplication>false</ShareApplication> <ExclusiveDownload>false</ExclusiveDownload> <HttpReferer /> <SetupInstructions /> <Variables /> <ExecuteCommand>7z x "{file}" -o"{root}GEGeek_Toolkit\ProgramFiles\{category}\Portable Update\" -y del /q "{root}GEGeek_Toolkit\ProgramFiles\{category}\Portable Update\*.zip"</ExecuteCommand> <ExecutePreCommand /> <ExecuteCommandType>Batch</ExecuteCommandType> <ExecutePreCommandType>Batch</ExecutePreCommandType> <Category>Windows Updates</Category> <SourceType>FixedUrl</SourceType> <PreviousLocation>i:\GEGeek_Toolkit\ProgramFiles\Windows Updates\Portable Update\PortUp.zip</PreviousLocation> <DeletePreviousFile>true</DeletePreviousFile> <Enabled>true</Enabled> <FileHippoId /> <LastUpdated>2017-08-02T14:13:27.7010078+10:00</LastUpdated> <TargetPath>{root}GEGeek_Toolkit\ProgramFiles\{category}\Portable Update\</TargetPath> <FixedDownloadUrl>http://www.portableupdate.com/public/PortUp.zip</FixedDownloadUrl> <Name>Portable Update</Name> </ApplicationJob> </Jobs> I am at a lost now. 795 applications all seem to be a dud and returning false information.
  11. Updating Bug

    So how does this fix the issue overall. Right now its not just the file on my server but also everywhere else. 900+ applications, 12000 members and too many emails from people choosing update all and all coming back with green ticks and nothing was downloaded
  12. Updating Bug

    Ive been using the beta version. Below is 1.8.7 24/07/2017 1:43:44 PM: Update started with 1 application(s) 24/07/2017 1:43:44 PM: Avast: Using referer: (none) 24/07/2017 1:43:44 PM: Avast: Server source file: /documents/Downloads/Toolkit_Files/AVUninstallers/Avast/UninstallTool/avastclear.exe 24/07/2017 1:43:44 PM: Avast: Determined target file name: h:\GEGeek_Toolkit\ProgramFiles\Anti Virus Uninstallers\Avast\avastclear.exe 24/07/2017 1:43:44 PM: Avast: Checking if update is required... 24/07/2017 1:43:44 PM: Avast: Update not required, since date and file size remain unchanged 24/07/2017 1:43:45 PM: Update finished This first one is with the Ignore File information ticked <?xml version='1.0' encoding='utf-8'?> <Jobs> <ApplicationJob xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" Guid="96dd4481-da75-4cd7-b230-a3c700587546"> <WebsiteUrl /> <UserAgent /> <UserNotes /> <LastFileSize>8553032</LastFileSize> <LastFileDate>2017-06-29T03:31:00.2646935</LastFileDate> <IgnoreFileInformation>true</IgnoreFileInformation> <DownloadBeta>Default</DownloadBeta> <DownloadDate xsi:nil="true" /> <CheckForUpdatesOnly>false</CheckForUpdatesOnly> <VariableChangeIndicator /> <HashVariable /> <HashType>None</HashType> <CanBeShared>true</CanBeShared> <ShareApplication>false</ShareApplication> <ExclusiveDownload>false</ExclusiveDownload> <HttpReferer /> <SetupInstructions /> <Variables /> <ExecuteCommand /> <ExecutePreCommand /> <ExecuteCommandType>Batch</ExecuteCommandType> <ExecutePreCommandType>Batch</ExecutePreCommandType> <Category>Anti Virus Uninstallers</Category> <SourceType>FixedUrl</SourceType> <PreviousLocation>h:\GEGeek_Toolkit\ProgramFiles\Anti Virus Uninstallers\Avast\avastclear.exe</PreviousLocation> <DeletePreviousFile>true</DeletePreviousFile> <Enabled>true</Enabled> <FileHippoId /> <LastUpdated>2017-06-29T03:31:00.2646935</LastUpdated> <TargetPath>{root}GEGeek_Toolkit\ProgramFiles\{category}\Avast\</TargetPath> <FixedDownloadUrl>http://www.gegeek.com/documents/Downloads/Toolkit_Files/AVUninstallers/Avast/UninstallTool/avastclear.exe</FixedDownloadUrl> <Name>Avast</Name> </ApplicationJob> </Jobs> This one isnt and yet same issue <?xml version='1.0' encoding='utf-8'?> <Jobs> <ApplicationJob xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" Guid="96dd4481-da75-4cd7-b230-a3c700587546"> <WebsiteUrl /> <UserAgent /> <UserNotes /> <LastFileSize>8553032</LastFileSize> <LastFileDate>2017-06-29T03:31:00.2646935</LastFileDate> <IgnoreFileInformation>false</IgnoreFileInformation> <DownloadBeta>Default</DownloadBeta> <DownloadDate xsi:nil="true" /> <CheckForUpdatesOnly>false</CheckForUpdatesOnly> <VariableChangeIndicator /> <HashVariable /> <HashType>None</HashType> <CanBeShared>true</CanBeShared> <ShareApplication>false</ShareApplication> <ExclusiveDownload>false</ExclusiveDownload> <HttpReferer /> <SetupInstructions /> <Variables /> <ExecuteCommand /> <ExecutePreCommand /> <ExecuteCommandType>Batch</ExecuteCommandType> <ExecutePreCommandType>Batch</ExecutePreCommandType> <Category>Anti Virus Uninstallers</Category> <SourceType>FixedUrl</SourceType> <PreviousLocation>h:\GEGeek_Toolkit\ProgramFiles\Anti Virus Uninstallers\Avast\avastclear.exe</PreviousLocation> <DeletePreviousFile>true</DeletePreviousFile> <Enabled>true</Enabled> <FileHippoId /> <LastUpdated>2017-06-29T03:31:00.2646935</LastUpdated> <TargetPath>{root}GEGeek_Toolkit\ProgramFiles\{category}\Avast\</TargetPath> <FixedDownloadUrl>http://www.gegeek.com/documents/Downloads/Toolkit_Files/AVUninstallers/Avast/UninstallTool/avastclear.exe</FixedDownloadUrl> <Name>Avast</Name> </ApplicationJob> </Jobs> It tells me that the file doesnt need updating yet in the programfiles directory there are no files.
  13. Updating Bug

    This issue is now severly serious, hundreds of people cant download. Ive even started from scratch and still the same issue.
  14. Updating Bug

    Any comments or suggestions?
  15. Green Tick Vs Yellow

    Is there a custom column option to display the icons so when I click it puts all the yellows into order and all the green ticks into order so they're not scattered all over the place? Thanks
  16. Green Tick Vs Yellow

    Yes I did realise this after posting lol
  17. Updating Bug

    Now have a serious issue. I have nothing in the ProgramFiles, if I right click and choose check for update it now comes back with a green tick and says no update, this couldnt be any worse. This is coming from FileHippo 11/07/2017 5:33:15 PM: .NET Framework Version: Using referer: (none) 11/07/2017 5:33:16 PM: .NET Framework Version: Server source file: /download/file/cf1422779457ca44389fb09c5eec1128a64dea8f1c615c28b907d0ff1e466d77 11/07/2017 5:33:16 PM: .NET Framework Version: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Apps To Install\.NET Framework Version\NDP47-KB3186497-x86-x64-AllOS-ENU.exe 11/07/2017 5:33:16 PM: .NET Framework Version: Checking if update is required... 11/07/2017 5:33:16 PM: .NET Framework Version: Update not required, since date and file size remain unchanged 11/07/2017 5:33:17 PM: Update finished File hasnt even downloaded yet. FireFox: also FileHippo 11/07/2017 5:34:26 PM: Firefox: Using referer: (none) 11/07/2017 5:34:27 PM: Firefox: Server source file: /download/file/980836087a9baa42859ff1175292123d7ba18edfa750fc6a2d3dfb7f0f591d2a 11/07/2017 5:34:27 PM: Firefox: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Apps To Install\Firefox\Firefox Setup 54.0.1.exe 11/07/2017 5:34:27 PM: Firefox: Checking if update is required... 11/07/2017 5:34:27 PM: Firefox: Update not required, since date and file size remain unchanged 11/07/2017 5:34:27 PM: Update finished 11.782 members all having to right click Force Download because Check For Updates doesnt work. Not happy. Its not just FileHippo its coming from a lot of sites. Even my own domain.
  18. Updating Bug

    29/06/2017 8:06:33 PM: Avira AV: Server source file: /download/file/4a53fc60dffb4ba749a33f7f81e3a71e11ca7713ddc310b2b762aa5962286d04 29/06/2017 8:06:33 PM: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 29/06/2017 8:06:33 PM: Avira AV: Checking if update is required... 29/06/2017 8:06:33 PM: Avira AV: Update required, MD5 does not match 29/06/2017 8:06:33 PM: Avira AV: Skipped downloading updates 29/06/2017 8:06:34 PM: Update finished Cant get this one either. Stays on yellow.
  19. Updating Bug

    This doesn't always work, when telling the list to update I get an error, I check the error and the file is still there. I do a manual check update on that one app and it tells me Update not required, since date and file size remain unchanged How would it know this if the file hasn't even been downloaded. I deleted all the applications before hand.
  20. Updating Bug

    So when an update is released from Blah company it will let me know there is an update?
  21. Updating Bug

    This application AltTabPlus Portable from MajorGeeks Download URL: http://www.gegeek.com/documents/downloads/toolkit_files/AltPlusTab.exe Variable >> Content from URL: http://www.majorgeeks.com/mg/getmirror/altplustab,1.html This line is extracted: <!-- Debug: http://files2.majorgeeks.com/a7b24870be7dd0354bf48eabb64506983dd61d88/appearance/APT.zip --> The command section says: 7z x "{file}" -o"{root}GEGeek_Toolkit\ProgramFiles\{category}\AltTabPlus Portable\" -y del /q "{root}GEGeek_Toolkit\ProgramFiles\{category}\AltTabPlus Portable\*.zip" and yet also has a green tick Updating Log File: 21/06/2017 07:02:47: AltTabPlus Portable: Using referer: http://www.majorgeeks.com/mg/getmirror/altplustab,1.html 21/06/2017 07:02:48: AltTabPlus Portable: Server source file: /documents/downloads/toolkit_files/AltPlusTab.exe 21/06/2017 07:02:48: AltTabPlus Portable: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Configurations\AltTabPlus Portable\AltPlusTab.exe 21/06/2017 07:02:48: AltTabPlus Portable: Checking if update is required... 21/06/2017 07:02:48: AltTabPlus Portable: Update not required, since date and file size remain unchanged 21/06/2017 07:02:49: Update finished
  22. Can someone please explain how the update actually works? When I upload a file to the server and check for update it tells me an update is available, ok all well and good since I just updated it. But if I close Ketarin and re open and do another scam it tells me that an update is available. How does Ketarin actually know if an update is available? Is there a custom value I can use to check or trigger something? Some help please. Thank you.
  23. What warrants Ketarin to update?

    Nothing is in that section and that box is always set to none on all apps XML: <?xml version='1.0' encoding='utf-8'?> <Jobs> <ApplicationJob xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" Guid="aa797d17-5c7b-4fb2-9ae3-6a4fa9b6ee19"> <WebsiteUrl /> <UserAgent /> <UserNotes /> <LastFileSize>4799712</LastFileSize> <LastFileDate>2017-06-13T02:18:19.2900959</LastFileDate> <IgnoreFileInformation>false</IgnoreFileInformation> <DownloadBeta>Default</DownloadBeta> <DownloadDate xsi:nil="true" /> <CheckForUpdatesOnly>false</CheckForUpdatesOnly> <VariableChangeIndicator /> <HashVariable /> <HashType>None</HashType> <CanBeShared>true</CanBeShared> <ShareApplication>false</ShareApplication> <ExclusiveDownload>false</ExclusiveDownload> <HttpReferer /> <SetupInstructions /> <Variables /> <ExecuteCommand /> <ExecutePreCommand /> <ExecuteCommandType>Batch</ExecuteCommandType> <ExecutePreCommandType>Batch</ExecutePreCommandType> <Category>Malware Removal</Category> <SourceType>FileHippo</SourceType> <PreviousLocation>c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe</PreviousLocation> <DeletePreviousFile>true</DeletePreviousFile> <Enabled>true</Enabled> <FileHippoId>avira</FileHippoId> <LastUpdated>2017-06-13T02:18:19.2900959</LastUpdated> <TargetPath>{root}GEGeek_Toolkit\ProgramFiles\{category}\Avira AV\</TargetPath> <FixedDownloadUrl /> <Name>Avira AV</Name> </ApplicationJob> </Jobs> Just did another check and same information 14/06/2017 07:48:42: Update started with 1 application(s) 14/06/2017 07:48:43: Avira AV: Using referer: (none) 14/06/2017 07:48:46: Avira AV: Server source file: /download/file/481153927c251aca22fa18a882805a3079c99218e06bc0ca0519f2f2d57505d8 14/06/2017 07:48:46: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 14/06/2017 07:48:46: Avira AV: Checking if update is required... 14/06/2017 07:48:47: Avira AV: Update required, MD5 does not match 14/06/2017 07:48:47: Avira AV: Skipped downloading updates 14/06/2017 07:48:47: Update finished
  24. What warrants Ketarin to update?

    Also look at this, this is Avira AV 1. All files are deleted 2. Check for update, update required 3. Update 4. Check for update, update required, md5 doesn't match, repeat... This is coming from Filehippo. 13/06/2017 02:16:38: Avira AV: Using referer: (none) 13/06/2017 02:16:41: Avira AV: Server source file: /download/file/9fca22d86da764c0249476769aeccbca4fc92b5ebe3266279e1c489aa37a9d27 13/06/2017 02:16:41: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 13/06/2017 02:16:41: Avira AV: Checking if update is required... 13/06/2017 02:16:41: Avira AV: Update required, 'c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe' does not yet exist 13/06/2017 02:16:41: Avira AV: Skipped downloading updates 13/06/2017 02:16:41: Update finished 13/06/2017 02:17:30: Update started with 1 application(s) 13/06/2017 02:17:31: Avira AV: Using referer: (none) 13/06/2017 02:17:33: Avira AV: Server source file: /download/file/5c5c2094338b290c538ba09f2a8ce7c9e00ce7e56a38998713054851d67476fa 13/06/2017 02:17:33: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 13/06/2017 02:17:33: Avira AV: Checking if update is required... 13/06/2017 02:17:33: Avira AV: Update required, 'c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe' does not yet exist 13/06/2017 02:17:39: Update finished 13/06/2017 02:17:41: Update started with 1 application(s) 13/06/2017 02:17:42: Avira AV: Using referer: (none) 13/06/2017 02:17:43: Avira AV: Server source file: /download/file/bfa90d9ac8c16df5b1c765ec0c9cdbfe54dac0a39b9f45613fda90facd94337e 13/06/2017 02:17:43: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 13/06/2017 02:17:43: Avira AV: Checking if update is required... 13/06/2017 02:17:44: Avira AV: Update required, MD5 does not match 13/06/2017 02:17:44: Avira AV: Skipped downloading updates 13/06/2017 02:17:44: Update finished 13/06/2017 02:18:02: Update started with 1 application(s) 13/06/2017 02:18:03: Avira AV: Using referer: (none) 13/06/2017 02:18:05: Avira AV: Server source file: /download/file/3f7e71a6e631ba2cf179d3694eeca2118c8eb66bc543fcba94bbc87fe0ca36a6 13/06/2017 02:18:05: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 13/06/2017 02:18:19: Update finished 13/06/2017 02:18:20: Update started with 1 application(s) 13/06/2017 02:18:21: Avira AV: Using referer: (none) 13/06/2017 02:18:22: Avira AV: Server source file: /download/file/ee1f48236b02e44058f8332bcf2efa3d734d7f96835d5316ce14c55404c77393 13/06/2017 02:18:22: Avira AV: Determined target file name: c:\GEGeek_Toolkit\ProgramFiles\Malware Removal\Avira AV\avira_en_free0___flh.exe 13/06/2017 02:18:22: Avira AV: Checking if update is required... 13/06/2017 02:18:22: Avira AV: Update required, MD5 does not match 13/06/2017 02:18:22: Avira AV: Skipped downloading updates 13/06/2017 02:18:23: Update finished
  25. What warrants Ketarin to update?

    None of those boxes are ticked across all 900+apps. I do have a question. I have noticed that on some websites when using the default commands, 7z extract, then delete, when it comes time to check for an update it wil say there is an update in the view log because it cant find filename blah.zip hencely because the default command deleted it. So if I remove that command and try again then it works. Issue: What happens after I release say 5 updates, all of a sudden I am going to have all these excess blah.zip files still hanging around because that delete command isn't in there. How do I combat this? I've tried to wrap my head around the variable option but that is really confusing. Thanks
×